Back to overview
Resolved

Mail Server Fault

Jul 17, 2026 at 11:13am UTC
Affected services
Ravindu (Falkenstein, Germany) - Main

Resolved
Jul 18, 2026 at 8:14am UTC

The mail server issue has been identified and successfully resolved.

Created
Jul 17, 2026 at 11:13am UTC

Due to a current error, the mail server is not accessible.